BoardPackager recommends using Google Chrome, but also works well in Firefox, Safari, Edge, and Internet Explorer 11.


Unfortunately, we are unable to support browsers that are no longer supported by their own manufacturers (such as older versions of Internet Explorer).